45110 Yunusemre, Manisa, Türkiye
05556064244

Wamp Arayüzünde Çalışmayan Proje Linkleri

Wamp Server’ın son sürümünde localhost’un ana dizinindeki indexin (ki kendisi çok kullanışlıdır) Projects altındaki linklerin çalışmadığını farkettim. Bu sorun herkeste var mı yoksa herhangi bir sebepten dolayı bana mı denk geldi bilmiyorum ama google’da sorunu ingilizce anlatınca aynı durumdan muzdarip bir sürü gavur çıktı. Ben de bu basit sorunun basit çözümünü paylaşayım, belki birisine faydası dokunur diye düşündüm.

Projects diye bir bölüm var arayüzde. Localhost ana dizinindeki klasörleri gösteriyor. Bendeki durum şuydu:

Diyelim ki deneme diye bir klasörümüz var. Projects bölümünde deneme klasörünün bağlantısı “deneme/” şeklinde görülüyor, bu yüzden tıklandığında sayfa bulunamıyor. Olması gereken ise “localhost/deneme/”

Localhost dizinimize gidelim. (genellikle C:\wamp\www)

index.php’yi bir editör ile açıyoruz.

Şu şekilde bir arama yapıyoruz

if (is_dir($file) && !in_array($file,$projectsListIgnore))

Düzenlememiz gereken kısım, bu if’ten sonra gelen süslü parantezlerin arasında.

$projectContents .= ‘<li><a href=”‘.($suppress_localhost ? ‘http:// : ”).$file.’”>’.$file.'</a></li>’;

Muhtemelen bu şekilde görünüyor. Tam olarak böyle olmayabilir düzeltmeden önce nasıldı hatırlamıyorum. Bu satırı şu şekilde düzenleyin.

$projectContents .= ‘<li><a href=”‘.($suppress_localhost ? ‘http://localhost/’ : ”).$file.’”>’.$file.'</a></li>’;

Kaydedip tarayıcımızda tekrar localhost’a gittiğimizde linklerin çalıştığını göreceksiniz.

Hazır elim değmişken Türkçeleştireyim bari dedim. Ortaya böyle bir şey çıktı.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir